You will find complete help sections under each Netkiosk version.

NETKIOSK SYSTEM REQUIREMENTS.

  1. Please read the install help page before, or after, you install Netkiosk.
  2. Netkiosk works on all devices running Windows XP (Service Pack 3), Windows 7 ,8,  and 10.
  3. Netkiosk can be installed on PC’s, Laptops or Windows Tablets.

Ctrl+Alt+Del Options (Windows 7 and 10)

  • Please contact us if you need help with the Ctrl+Alt+Del settings on your device(s).
  • Ctrl+Alt+Del settings are not needed on touch screen devices.

Minimum screen resolution for both Netkiosk versions:1024 X 768


All Netkiosk versions require Microsoft .NET Frame work 4.5.1
Netkiosk imperi 2020 requires Microsoft .NET Frame work 4.6.1

  1. If not installed already Netkiosk will try to install this automatically.
  2. Windows 8 and 10 have .NET Framework 4.5 built-in. So no need to install.
  3. Microsoft .NET FrameWork 4.5.1 (Direct download links to Microsoft website)
  4. If you have problems running Netkiosk please install Microsoft .NET Framework 4.5 (FULL VERSION)
  5. Netkiosk imperi 2020 requires Microsoft .NET Framework 4.6.1  and Microsoft Visual C++ Redistributable. Netkiosk will check if these are already installed. 

Adobe Acrobat Reader and Flash Player  (Optional)

  1. You need to make sure you have Adobe Acrobat Reader installed if you want to allow proper access to PDF files and your Flash player is up to date.
  2. Note: Please make sure that you do not install, and try to run, each Netkiosk version on the same PC, at the same time.

Installing Netkiosk on Windows 10.

It is completely safe to install Netkiosk on Windows 10.
The Security Window is common on Windows 10.
The same applies to other Netkiosk versions.

1) Click on more info
2) Click run anyway.
3) Continue with the installation of Netkiosk.